Cannot link to Stellarium

Hi Sebastian,
I’ve been trying to get Telesciopius to control Stellarium, but not having much luck so far.

I’ve carefully followed the configuration instructions, and I can open the Stellarium remote control interface in a webpage by entering the URL http://localhost:8090.

But, when I try in Telescopius, I get the message ‘Could not connect to Stellarium …’.

Do you have any suggestions ?

Stellarium : 0.21.2
Telescopius : 20210902.1848
Mac : OX 10.14.6

Best regards,

Gary

I had / have the same problem…I thought it may just be my lack of understanding the process.

Following this topic for sure…

I have just tried and opened a target in Stellarium versions 20, 21.0 and 21.2 without problems from Chrome, but I did find a problem with Safari: it’s blocking “insecure” resources. In other words, since we are requesting an HTTP resource from a secure HTTPS page, it’s being blocked. This is also known as mixed content.

Unfortunately, I’m afraid there’s not much I can do from Telescopius side, I believe the Remote Control plugin in Stellarium should have a new feature to serve content with a secure server i.e. HTTPS instead of HTTP. Maybe you could open an issue/request in Stellarium’s Github page? https://github.com/Stellarium/stellarium

In case you are using Chrome, here you have a couple of ideas to check:

  • Verify your Stellarium version - this integration works starting at Stellarium version 20
  • @Lockwood Check you can open the remote control interface by going to http://localhost:8090 as Gary did. This should definitely work before Telescopius can communicate with Stellarium. If that doesn’t work, you should review the Remote Control plugin settings in Stellarium.
  • Make sure the RC plugin doesn’t have any password first (uncheck “Access requires authentication”), it’s easier to test.
  • Make sure “Enable CORS…” is checked, and the text field at the right is set to * (asterisk). Once it works you can replace that with “https://telescopius.com” (without quotes) to only let Telescopius and control your Stellarium server and no other website.
  • Make sure you hit “Restart server” after making any change in RC plugin settings.
  • Make sure you save your RC plugin settings after making it work.

Just for reference, here’s how I have my RC plugin configured right now.

Hi Sebastian,
Many thanks for that feedback …

OK - the link to Stellarium works perfectly OK when using Chrome, also Firefox, whether using “*” or “https://telescopius.com” in the CORS field.

But not when using Safari (at least not Version 14.1.2 (14611.3.10.1.7) !

Just one of those things :slight_smile:

Gary

Hi Sebastian,
I was using Telescopius again yesterday to plan last night’s session … hoping to link to Stellarium to confirm target locations.

Unfortunately, neither Chrome nor Firefox work now …

I can’t think of anything that’s changed at my end - Ive tried all the usual things like restarting & rebooting, but they just don’t work any more, even when using “*” for the CORS address.

I will keep trying and post progress here.

Gary