Impossible open Telescopius site

Good morning,

I haven’t been able to open the telescopius website from a browser for a few days. i tried firefox, chrome and edge to no avail. only the application on the smartphone works, could you help me?

Welcome to the forum Giafol!

I have just opened Telescopius on Safari, Chrome and Firefox on a Mac and it worked just fine.

Could you please let me know which browser versions you are running, and which Operating System?

Have you tried opening Telescopius on an incognito window? What about clearing your browser cache?

Also, what exactly means to be unable to open the site? What do you see? A blank screen? The loading screen? The homepage without content? Any extra info you could share could be useful to help you.

Yes, Im having exactly the same problem …

I am using a Mac :-

  • OSX 10.14.6
  • Safari 14.1.2 (14611.
  • Chrome v 93.0.4577.82 (Official Build) (x86_64)
  • Firefox 92.0 (64-bit)
  • Telescopius version 20210902.1848

Telescopius responds exactly the same way for each browser …
It loads the page template very quickly, but takes a very long time (up to minutes) to load content.

I hope that helps :1st_place_medal:

By the way - Telescopius behaves the same way on my iPhone.

I have very fast broadband - 100+mb/s, so Ive eliminated my internet connection as causing this behaviour.

I hope we can fix this issue because Telescopius is very good, and has become an important part of the workflow for my amateur astrophotography …

Thanks again Sebastian for building such a great website :slight_smile:

Just opened Telescopius with Safari, Firefox and Chrome. No problems. Latest versions of each browser running on a MacBook with MacOS 11.5.2. It’s working great for me. I clear cache and cookies regularly and reboot my Mac every couple of days or so. Internet is through a local provider (not one of the big guys).

1 Like

This issue is a tough one. I can also open Telescopius on all browsers and devices, and runs quite quickly after I fixed a performance issue several weeks ago affecting all versions.

Those having issues: could you please try opening on an incognito/private window and let me know if it loads properly that way? I’m not suggesting this is the solution but it’s really hard for me to fix a bug I can’t reproduce. If Telescopius loads well on an incognito window then I can probably narrow down the issue a bit.

Hi Sebastian,
Many thanks for that feedback … Ive run a couple of additional tests for you, using different browsers in private mode :-

Here are the results, total times in minutes/seconds for the site to respond, to load the landing page template, and to load the landing page including content.

  • Telescopius version 20210902.1848

iMac 27" : OS 10.14.6
Safari____14.1.2 (14611.
Firefox___92.0 (64-bit)____________1:14_____1:16____1:18
Chrome__v 93.0.4577.82__________1:09_____1:14____1:20

I tried this on my iPad 13" (iOS 14.7.1) last night - Telescopius still hadn’t responded after more than 10 minutes.

I’m in Sydney Australia - for others doing similar tests, it might be worth noting your location.



1 Like

I think this does tell us something useful …

In each case, the content was loaded just a few seconds after the server responded, but it took a long time (minutes) for the server to respond.

In ‘normal’ browsing mode, the Template is cached, so the landing page is already there in the cache, which gives the impression that the delay is just to load content.

In ‘private’ mode, the template is not cached, so the landing page is not loaded until the server responds. If you go to the website and wait, the server does eventually respond and loads the landing page after a minute or two, then loads content in a few seconds. If you then refresh the page, the template stays there (because its in the private cache already), but it often still takes several minutes to respond and load the content.

Just now, I tried refreshing the page, the landing page template was still there but the content was removed, and then displayed an error message something like ‘There was a connection error - please try again’ - but it disappeared before I had time to grab a screen shot. After that, the spinning gear was displayed continuously, but after waiting 15 minutes, content was never loaded.

So - there seems to be something causing the server to wait for several minutes (or forever) before it responds to a request.

I hope that helps :slight_smile:

1 Like

Thank you for your tests, Gary!

The server has a timeout of 30 seconds to respond to requests. This means the moment the server gets the request, if a response could not be sent 30 seconds later, the request is canceled altogether.

If you are getting a response after 2 minutes, this probably means the request does not reach the server for a long time, and when it does the response is sent in under 30 seconds.

Moreover, the different behavior you describe between private/non private browsing makes me think there might be some connectivity issues for the first request, and after that subsequent requests pass just fine. In other words, in private mode content is loaded just a few seconds after the template is downloaded, but since it’s actually a completely separate request I would expect the same delay. However, content is downloaded only a few seconds after the template. I normal / non-private mode, the first request is for the content and it does show that delay.

Have you tried using your mobile network - i.e. not wifi - to see if Telescopius loads properly that way?

Hmmmm - this is interesting …

If I use my iPhone via the mobile 4G network, the site responds in just a few seconds.
Without logging on - in Private mode, it loaded the template in about 5 seconds, and the ‘Whats in the sky tonight ?’ (WITST ) page in about 5 seconds.

After loging on, it behaved pretty much the same way - fast - including my Observing lists.

After switching back to my WiFI connection, (still in Private Mode) the site did not respond - ‘Safari could not open the page because the server stopped responding’.

Other sites responded perfectly OK and very fast.

I tried again - Telescopius loaded the template in about 5 seconds, and then loaded WITST in about 5 seconds.

Refreshing the page - still in private mode - the server did not respond - after 5 minutes the gear was still spinning.

For these tests I used Safari as opposed to the Telescopius pseudo app - but I assume it behaves the same way.

So the problem seems intermittent - but only sometimes :slight_smile:

I’m not sure what to suggest - but there must be a common cause because other users (or at least one other) is experiencing the same thing.

Giafol74 - are you still having the problem - and may I ask where you’re located - and which ISP do you use ?

I’ll try again later to see whether the behaviour is repeatable.


OK … this might help …

I set up 2 browser pages, one ‘Standard’ and one ‘Private’ - side by side.
Then I ran the same tests using two different connections to the internet :-

A. iMac > WiFI > iPhone > Optus 4G mobile network.
B. iMac > WiFi > AirPort Extreme > ethernet > cable modem > Telstra cable network

I entered ‘’ in each URL bar.
I started a screen recording, then hit ‘enter’ for each browser.

• iMac 27" Retina 5k
• OSX 10.14.6
• Safari 14.1.2 (14611.
• Telescopius version 20210902.1848

A. iMac > WiFI > iPhone > Optus 4G mobile network
Speed : Down = 6.5 mbps
Speed : Up = 1.1 mbps

** Standard**
00:00 - Hit ‘Enter’.
00:01 - Landing page template started loading.
00:02 - Landing page loaded - spinning gear appears.
00:05 - WITST loaded.
00:20 - Clicked ‘Toolbox/My Observing Lists’.
00:23 - Observing list loaded.

00:02 - Hit ‘Enter’.
00:03 - Progress bar loaded and progressing.
00:08 - Landing page template began loading.
00:12 - Landing page template loaded.
00:13 - WITST loaded.
00:26 - Clicked ‘Toolbox/My Observing Lists’ > had to log in.
00:48 - Logged in.
00:49 - Observing list loaded.

So - that all seems to work OK :slight_smile:

B. iMac > WiFi > AirPort Extreme > ethernet > cable modem > Telstra cable
Speed : Down = 110 mbps
Speed : Up = 6 mbps

** Standard**
00:00 - Hit ‘Enter’.
00:00 - Landing page template started loading immediately.
00:01 - Landing page template loaded but empty → spinning gear displayed.
05:26 - Error message ‘Connection Error, please refresh the page or try again later’.
05:31 - Message vanished, so did the spinning gear.
06:04 - No change.

00:00 - Hit ‘Enter’.
00:00 - Progress bar displayed.
00:02 - Progress bar stopped progressing.
00:30 - Error message :-
______'Failed to open page.
______Safari can’t open the page
______‘" because the
______server where this page is located isn’t
06:04 - No change.


The ‘Standard’ browser tried for 05:26 then gave up.
The ‘Private’ browser behaves consistently with a 30-second server timeout,
but delivers a meaningful message, whereas the ‘Standard’ browser kept trying.

So, the questions are :-

  1. what is causing the server to time out ?
  2. why does this happen when connecting via a fast cable network, but not when connecting via a slow 4G network ?

I hope that helps …



C. iPhone > WiFi > AirPort Extreme > ethernet > cable modem > Telstra cable

Telescopius pseudo app v 20210902.1848

00:00 - Launched Telescopius pseudo app
00:01 - Landing page template loaded immediately
00:02 - Gear wheel spinning - no progress indicator
01:20 - WITST page loaded
03:00 - Enter login credentials - gear spinning
04:07 - Login completed
04:08 - Clicked Telescopius Logo
04:09 - WITST header displayed - no content
05:45 - Error message ‘Connection Error, please refresh the page or try again later’
05:49 - Error message cleared - gear spinning
08:30 - Error message ‘Connection Error, please refresh the page or try again later’
08:35 - Error message cleared - gear spinning
10:00 - Test cancelled

This is bad.


D. iPhone > WiFi > AirPort Extreme > ethernet > cable modem > Telstra cable

Safari Private Browsing mode v 20210902.1848

00:00 - Entered ‘’ and Hit Enter
01:01 - Error message
______‘Safari could not open the page because the server stopped responding’

This is bad.


E. iPhone > Optus 4G mobile network

00:00 - Launched Telescopius pseudo app
00:01 - Landing page template loaded immediately
00:05 - WITST content loaded
00:10 - Tapped ‘My Observing Lists’
00:13 - Lists loaded.

This is good.


NB : Behaviour is THE SAME :-

  • on other Macs running different versions of the OS and Safari, on the same WiFi network.
  • when running different browsers (eg Chrome, Firefox).

So - the main suspect at this point is the WiFi > Telstra connection.

What could cause the website to fail on a very fast WiFI > cable connection,
but work OK on a slow 4G connection ?

More …

I tried the same tests using a direct ethernet connection from my iMac to my cable modern - bypassing the WiFI network and AirPort Extreme.

Speed Down = 110 Mb/s
Speed Up = 5.28 Mb/s

The website behaviour appears to be exactly the same as via WiFi.

After limited testing :-

  • in a standard window : Telescopius displayed the error message ‘Connection Error, please refresh the page or try again later’. This was repeated every 5 minutes or so.
    However, it DID download WITST after about 20 minutes.

  • in a private window : the gear icon kept spinning, there was no error message and no content was downloaded after 10 minutes.

I have no firewall, closed ports or anything like that …
All my bandwidth testing and other data-hungry websites work just fine.

So I’m at a loss to offer an explanation /:o

Over to you Sebastian :slight_smile:


Thank you so much for such detailed tests, Gary, I appreciate it!

I’m no expert on networking, but I can think of one thing: DNS. Maybe your WIFI > Telstra connection is having problems resolving What DNS servers are you using? Can you try replacing them with others, for example Google DNS? The primary and secondary IPs are and You can do so at your router level (then reconnecting to your wifi) or per device.

Other than that, I’m not sure what could be happening. In the meantime, I’ll keep researching.

Hi Sebastian,
Many thanks for your quick reply …

Yes, after sending my previous post I did wonder about DNS, but here’s the thing …

  1. Telescopius used to work just fine - this behaviour only began recently
  2. I haven’t changed anything with my setup here
  3. I’m not having similar issues with other websites
  4. Telescopius usually responds eventually, so the DNS is resolving the address correctly - at least sometimes.
  5. I’ve tested my iMacs using Optus DNS and Google DNS - these all work fine with other websites, unfortunately Telescopius still works the same as before :{

I can’t test different DNS addresses on my iPhone 4G because iOS doesn’t allow changing the DNS when connected to a cellular network.

I just re-tested using Safari on my Mac with the ‘default’ Telstra DNS.
After typing ‘’ in the URL bar and hitting 'return, the template loaded in a few seconds, then displayed the ‘spinning gear’ for 5 mins, 54 seconds before loading content.

Running the same test using Chrome, again the page template loaded quickly, but took 1:20 to display the error message ‘Connection error - please refresh the page or try again later’, which was dismissed automatically after 5 seconds (BTW - this needs to be longer - better to dismiss by an OK button). After 10 minutes, the website still hadn’t loaded any content.

So - over to you again Sebastian :slight_smile:


More …

Repeating the tests again using Safari and Firefox in PRIVATE mode :-

  • Both timed out and never loaded content after 2 hrs
  • After refresh, both loaded WITST eventually (after hours)

Trying again … after about 5 minutes

  • FF displayed ‘The session has timed out’
  • Safari displayed ‘The server isn’t responding’

Back to you Sebastian /:o



Would you mind running a traceroute to Telescopius server, to see if there is some intermediate node causing the delay in the response?


Sure Sebastian - no problem.
I ran TraceRoute to the domain name, and also to the IP address.

File attached - they look more-or-less identical - and nothing obvious AFAICT that might be causing the problem …

I entered in my browser URL - it went to ‘’, not ‘’ - and I received these messages :-


and then, after clicking ‘OK’, this :-

I hope this helps …



** END **

I’ll check why going to takes you to the old domain, but that’s really not the problem here so low priority.

Thank you for the traceroute. I find it weird that it skipped the ping to the actual server, it stopped one or two nodes before. Just for the record, this is one of my traceroutes:

traceroute to (, 64 hops max, 52 byte packets
1 ( 2.980 ms 0.980 ms 1.136 ms
2 ( 24.706 ms 41.762 ms 3.755 ms
8 ( 137.368 ms 142.323 ms 139.848 ms
9 ( 137.577 ms 136.819 ms 137.076 ms
10 ( 164.726 ms 160.967 ms 161.669 ms
11 * * *
12 ( 165.469 ms 165.635 ms 164.237 ms

The most notorious difference is that, while all traceroutes reached an Atlanta node, yours stopped right there while mine kept going 2 more hops (one unknown and then the actual Telescopius server).

I will open a ticket with Telescopius hosting to see if they can give us a hint. I suggest you do the same with Telstra.

@Giafol74 Where are you located? What’s your ISP? Could you please run a traceroute to and paste the results here?

At this point I’m suspecting there is some network issue beyond my reach.

@Gary I’m afraid the IP address I gave you is wrong, that’s an old one and is no longer working.

The correct IP address is - which is a DDoS filtered IP address I had to add a couple of years ago due to some attacks. I contacted my hosting and they say it’s possible your IP address/subnet is being blocked/throttled due to some previous attack in the same subnet.

To better undestand what’s going on, they asked me (us) to run a MTR from your computer to the server and back. For more info on MTR - What is MTR? - Knowledgebase - RamNode

Here is the MTR from Telescopius server to the first IP address I see on your traceroutes. Would you mind running a MTR to IP address and paste the results after at least 100 packets were sent?

$ mtr

                                      My traceroute  [v0.85] (                                                Fri Sep 17 15:18:48 2021
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                                         Packets               Pings
 Host                                                  Loss%   Snt   Last   Avg  Best  Wrst StDev
 1.                                        0.0%   243    1.0  12.0   0.4  40.3   5.8
 2.          0.0%   243    0.7   3.4   0.2  45.9   6.9
 3.                0.0%   243    1.4   2.5   0.4  24.6   3.8
 4.                 0.0%   243    1.1   0.9   0.7   3.8   0.2
 5.               0.0%   243    0.6   0.6   0.5   3.9   0.2
 6.                       23.9%   243   30.3  17.4  17.1  30.3   1.0
 7.                       43.2%   243   47.5  48.4  47.4  91.2   5.1
 8.     0.0%   242   46.6  48.9  46.6 100.5   6.9
 9.                  0.0%   242   47.7  49.5  47.0  69.8   2.6
10.                  0.0%   242  193.9 193.3 192.1 194.6   0.3
11.                  0.0%   242  193.9 193.4 192.2 200.5   0.6
12.           0.0%   242  194.3 193.3 192.2 194.5   0.3
13.         0.0%   242  190.6 190.7 188.8 192.6   0.4
14.      0.0%   242  202.4 203.3 201.5 217.4   1.0
15.       2.1%   242  201.4 202.2 201.3 202.8   0.1
16.       0.0%   242  201.4 202.2 201.3 204.8   0.3