Is the website down?

Is the Telescopius website down ? I have been unable to login for a day or so

thank you

Hi Lockwood,

No, it’s very alive and kicking. I’ve just tried it on an incognito window and I was able to log in using my username and password, as well as my Google account.

Have you tried using another device/browser or clearing your browser cache for Let me know how it goes!

1 Like

thank you for your prompt reply. I guess it is on my end. I wanted to check with your first before going through the steps on my end.

thank you again…love your website

I’m able to log in using the Chrome Browser, but I normally use Brave which has not allowed me to log in since yesterday.

Any suggestions ?

I downloaded the Telescopius App on my Desktop - screen shows up just like when I use the Brave Browser

No place to Login

See screen shot attached

I’ve recently introduced a feature to improve loading speeds by lazy loading some widgets. But I guess there is a bug after all.

I’ve just reverted this until I can check what’s going on. It should work as expected again starting version 20230930.1350

Let me know how it goes!

1 Like

Yes sir ! That did the trick

All is back to normal logging in with Brave browser

thank you sir

1 Like