New image display bug

Hi !

I uploaded a new image with all the equipment details. But the images don’t display (only the new ones).

It’s doing this both on the profil page and the picture page.
Here is on of the picture:

I can’t even delete or edit them.
I linked 2 screenshots with the console errors.

I tried on Safari and Brave browsers, both have the same issue.
I also cleared the cache and try in private navigation.
I also tried to change my TIFF file saving setting but it seems it didn’t work. I can send you both files if you can’t access them and think it might be related.

Thanks, and good luck ! :slight_smile:

After some testing, it’s because of my tiff files. I guess because I forgot to convert them to 16bits.

I uploaded a 16Bits version that works fine :slight_smile:

Also I managed to delete the failed one using the delete url and the pictures ids :slight_smile:

You’ve nailed it. There currently is a problem with some TIFF files, which are not being resized properly and the image page is left broken.

Thank you for reporting this issue, and I’m glad you were able to delete those broken images by tinkering with the URL, good job! :slight_smile:

If you could share your image with me so I can debug this issue, that’d be much appreciated. You can paste the link to the file at any file sharing platform here, or send me a private message if you’d rather keep that file private.


I am a software engineer reconverted to data science, can’t see a bug without trying to debug :smiley:
Even more as this tool is so useful ! Glad to help !

Here is the link of the files (available for 7 days) :

Thank you for the files! Do you experience this issue with both files inside the zip file, or just one of them?

Both of them !

If I remember well, I save the tiff as a 32bits tiff from Siril, then as it was too Big, I opened it with Photoshop to resize and test with and without compression.
Then I remembered that usually I export the Tiff in 16bit in Siril, so the working file is just a 16bit tiff from Siril

Now that I’ve finished with a huge under-the-hood refactor and the new comets and asteroids sections I came back to this :slight_smile:

I’ve raised this issue to the team maintaining the library we use to convert images and it seems it doesn’t support 16-bit TIFF files! The weird thing is when I check the details of your files on my Mac I can read “BITPIX = 32 bits per data pixel”, but when I run exiftool on your files I read it’s actually 16 bits.

Could you please try again but uploading a 32-bit version of the same image, to see if it works? Thank you!

Oh, now I see that you mentioned a successful 32-bit upload… I’m a bit confused now! I think the problem might be related to 16-bit int vs. 16-bit float. I believe the library doesn’t support 16-bit floating point TIFFs but it should work with 16-bit integer TIFFs…

I tested again :

  • Export as 16Bits from Siril works,
  • Export as 32Bits from Siril is too big, so I compressed it to 16bits with photoshop. And it doesn’t work.

I have a similar issue that may be related. My gallery page thumbnails are visible but when I click one to view enlarged nothing is displayed. Appears to be browser dependent: occurs with FireFox but not with Chrome.

Thank you for your feedback! So one 16-bit version works ok, and the other one does not. I’ll see what I can do about the 16-bit float format, maybe I need to re-convert those files to 16-bit int before processing. In the meantime, if Photoshop has that option when exporting the file, you might want to try that.

Thank you for your help understanding this issue, it was really helpful! :slight_smile:

You problem is probably related to a recent upgrade. Please try clearing your browser cache for and try again. That will probably fix your issue. Sorry for the inconvenience!

@sebastien I’m glad to let you know that I’ve found a workaround for this issue, at least until the resizing library (imgproxy) adds support for these files. I’m now detecting 16-bit float TIFF files before processing them and doing an intermediate lossless PNG conversion with a different tool.

Just FYI, in my tests - with the server quite idle,- your 170 MB file took about 50-60 seconds of processing after the upload finished. This workaround is not ideal because of the extra processing time, but at least it works now :slight_smile:

Thank you for your help and patience with this issue!